Jump to content
RETSPRO

How to test/debug failed RETS connection.

Recommended Posts

If you are just getting started for the very first time - or - have made changes to the server or hosting and now have problems connecting to the RETS server then this is the way to go about testing to find out what is going on - 
 

  1. Test RETS creds here - http://retsmd.com - if they work then next step below - if not - contact Board of Realtors.
  2. If credentials worked on retsmd.com then download retsmd https://github.com/t...hive/master.zip and install folder and test connections again on your local domain/server to verify that your RETS credentials still work - or not - If RETS credentials work on retsmd.com but NOT on the local retsmd script then we know that you need to open the following TCP in/out ports 6103 & 8080  - OR - Verify that the Board of Realtors isn't IP locking your credentials - (yes most boards already whitelist the retsmd.com IP so that's why it may also work there but not on your host) - Once we've confirmed that your creds >>"work"<< in the local retsmd script it should 100% be working with our script as well - if not then we will need you to open a ticket and provide us with creds so that we can have our team resolve the issue (which is extremely rare that it would be our script but I have seen it happen a couple of times over the last few years where we've needed to make a tweak for some RETS providers so it is possible but first we need to eliminate the other possibilities)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×